Поиск:     Расширенный поиск

При работе с RSA ошибка: cмарт-карта не может выполнить запрошенную операцию либо операция требует другую смарт-карту

ID статьи: 220
Последнее обновление: 17 Jan, 2018
Ревизия: 4
Добавить комментарий
Просмотры: 3258
Комментарии: 0

Версия ПО:  ЕК 2.7.х - 2.9.х

Токены:  JaCarta PKI

Проблема: 

При операции с сертификатами RSA на ключевом носителе JaCarta PKI (выпуск сертификата, вход в систему, подпись и др.) возникает ошибка: "смарт-карта не может выполнить запрошенную операцию, либо операция требует другую смарт-карту".

Причина:

При инициализации апплета PKI в ПК "Единый Клиент JaCarta" версий 2.7.х - 2.9.х создаётся файл с настройками, которые конфликтуют с новой версией минидрайвера ID-Protect 7.1.

Решение:

  • В диспетчере устройств удалить устройство ID-Protect (отметить флажок "Удалить программы драйверов для этого устройства"), переподключить токен. После переподключения токена установится предыдущая версия минидрайвера ID-Protect 6.1.

  • Инициализировать апплет PKI через ПК "Единый Клиент  JaCarta" более новой версии (начиная с версии 2.11.х), или через JC-WebClient. Единый Клиент версии 2.11 доступен по ссылке в центре загрузки - https://www.aladdin-rd.ru/support/downloads/jacarta .

  • Данный способ не подходит для пользователей ЕГАИС. Если инициализировать апплет нет возможности (требуется сохранить сертификат), то можно воспользоваться утилитой для исправления файла настроек апплета PKI без инициализации. Утилиту с инструкцией необходимо запросить через службу технической поддержки компании "Аладдин Р.Д.":

Создание нового обращения

Эта статья была:  
Теги
ошибка RSA Смарт-карта не может выполнить запрошенную операцию

Также опубликовано в
folder JaCarta -> Единый клиент JaCarta
folder JaCarta -> JaCarta PKI

Пред.   След.
KB0245 Вход в Active Directory на рабочей станции Linux, используя...     KB0257 В Едином Клиенте JaCarta ключевой носитель при подключении...