Ошибка Aladdin 2FA Service: "DB upgrading [] to [1.0] has been failed. Reason: ОШИБКА: ошибка синтаксиса (примерное положение: \"GENERATED\") (SQLSTATE 42601)"

ID статьи: 484
Последнее обновление: 31 Jan, 2024
ID статьи: 484
Последнее обновление: 31 Jan, 2024
Ревизия: 1
Просмотры: 87
Комментарии: 0

Источник возникновения симптома (ошибка в EventViewer/JAS/логи A2FA/ошибки мобильного приложения/визуальные ошибки в мобильном приложении):

файлы логов Aladdin2FAService: main.log

Версия ПО:

Версия 1.3.0 и выше

Проблема:

Сервис не запускается. В файле логов main.log выводится ошибка:

"error":"DB upgrading [] to [1.0] has been failed. Reason: ОШИБКА: ошибка синтаксиса (примерное положение: \"GENERATED\") (SQLSTATE 42601)"

Решение:

Данная ошибка связана с версией СУБД PostgreSQL 9.6 в составе ASTRA Linux 1.6, которая уже не поддерживается сервисом Aladdin2FAService.

Возможные решения:

  • Обновить СУБД PostgreSQL до версии, которая поддерживается Aladdin2FAService;
  • Развернуть СУБД PostgreSQL отдельно от сервера Aladdin2FAService;
  • Развернуть СУБД, используя средства виртуализации (например, docker).

Список СУБД, с которыми подтверждена совместимость есть на странице продукта:

https://www.aladdin-rd.ru/catalog/aladdin_2fa

Эта статья была:  
Сообщить об ошибке
ID статьи: 484
Последнее обновление: 31 Jan, 2024
Ревизия: 1
Просмотры: 87
Комментарии: 0
Теги