Ошибка при удалении КриптоПро CSP 4.0.9963 или ниже с использованием модуля поддержки JaCarta на Linux

ID статьи: 360
Последнее обновление: 31 Jan, 2021
ID статьи: 360
Последнее обновление: 31 Jan, 2021
Ревизия: 1
Просмотры: 23
Комментарии: 0

Версия ПО:  КриптоПро CSP 4.0.9963 и ниже, ОС Linux

Токены:  Любые

Проблема: 

При попытке удаления/переустановки криптопровайдера КриптоПро CSP 4.0.9963 (и более ранние версии), который ранее был настроен для работы с ключевыми носителями JaCarta (добавлен модуль поддержки JaCarta) на ОС Linux возникает ошибка:

dpkg: error processing package cprocsp-rdr-jacarta-64 (--purge):  installed cprocsp-rdr-jacarta-64 package post-removal script subprocess returned error exit status 255

Причина:

В пакете cprocsp-rdr-jacarta-64 версии 3.6.408.695 (и более ранних версий) присутствует некорректный скрипт удаления.

Решение:

  • Необходимо выполнить команду:

            sudo rm /var/lib/dpkg/info/cprocsp-rdr-jacarta-64.*

  • Далее можно выполнять удаление КриптоПро CSP стандартным способом

               Для предотвращения такого поведения рекомендуем использовать модуль поддержки JaCarta под Linux (cprocsp-rdr-jacarta-64) версии 3.6.408.720 или выше. Модуль поддержки доступен в составе архива дистрибутива КриптоПро CSP 4.0 R5. Также данный модуль можно запросить, создав обращение в техническую поддержку "Аладдин Р.Д.", ссылаясь на данную статью.  Форма для обращения находится по адресу: https://www.aladdin-rd.ru/support/tickets/create.

Эта статья была:  
Сообщить об ошибке
ID статьи: 360
Последнее обновление: 31 Jan, 2021
Ревизия: 1
Просмотры: 23
Комментарии: 0
Теги