В ОС Linux плагин для работы с порталом государственных услуг не позволяет выбрать сертификат ЭП

ID статьи: 418
Последнее обновление: 24 Jun, 2022
ID статьи: 418
Последнее обновление: 24 Jun, 2022
Ревизия: 1
Просмотры: 253
Комментарии: 0

Версия ПО:  IFCPlugin 3.1.1

Токены:  JaCarta-2 PKI/ГОСТ, JaCarta-2 PRO/ГОСТ, JaCarta-2 ГОСТ.

Проблема: 

       В ОС Linux при входе на портал государственных услуг невозможно выбрать сертификат ЭП. В логе регистрируется запись:

2022-06-12 14:07:30:IFC:ifc_list_certificates_in_store:no public key found -> skip XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXX

Причина:

В состав IFCPlugin входит устаревшая версия библиотеки JaCarta PKCS#11

Решение:

  • Необходимо скачать и установить актуальную версию ПО Единый клиент JaCarta.
  • Необходимо в конфигурационном файле /etc/ifc.cfg секции JaCarta заменить строку:

lib_linux = "libjcPKCS11-2.so.2.4.3";
на строку:
lib_linux = "libjcPKCS11-2.so";

Эта статья была:  
Сообщить об ошибке
ID статьи: 418
Последнее обновление: 24 Jun, 2022
Ревизия: 1
Просмотры: 253
Комментарии: 0
Теги

Также опубликовано в